Changing Custom Layers

DaanKerkhof wrote:

Hi Andy,

I tried your new module this afternoon.

Is there a way to change custom fader bank B between layers 1/2/3/4?

Let’s see… it’s likely FaderBank/Bank/Recall and then select FaderBank 1,2 or 3.
2 is probably the “B” bank, and then 1-8 for the Bank to recall.
If you only have 4 banks, then 1-4. Not sure what recalling Bank 0 would do or if that’s valid…

I’ll give that a try tomorrow.

Doesn’t seem to work for me.
I can switch between A and B with /FaderBank/Select, with A being “off” and B being “on”.
Don’t seem to be able to switch between B1/B2/B3/B4.

Did you try doing performing the action on the console while recording a macro?
Using the macro record it will record the correct action if there is one.

You can also see the messages coming from the console in the debug log.

Any luck with this?

Doesn’t seem to work, but I need to take a little more time to mess with this in detail.

What doesn’t work? Macros in general, or just the custom layer messages? :dontknow:
What messages are being received? (look at the log)

More info is more helpful.:poke:

Hi Andy,

I did some testing, and I have the following log for you:

Instance(yamaha-scp): Unknown command received: QL:Current/FaderBank/Recall’
Instance(Yamaha-scp): Received from device: ‘NOTIFY set QL: Current/FaderBank/Bank/Recall 0 1 1 “1”’

Device(xxx): Button 7.20 released
Instance(Yamaha-scp): Received from device: ‘ERROR set UnknownAddress’
Device (xxx): Button 7.20 pressed
Instance(Yamaha-scp): sending ‘set CL:Current/FaderBank/Recall 0 0 1’ to

Top one is when I press a different faderbank on the desk.
Bottom one is when I press a button on the stream deck that is configured as 'FaderBank/Bank/Recall & FaderBank 1 & Bank 1.

As far as I can gather, the fader banks get an output as follows when I push buttons:
A1: Current/FaderBank/Bank/Recall 0 0 0 “0”
A2: Current/FaderBank/Bank/Recall 0 0 1 “1”
A3: Current/FaderBank/Bank/Recall 0 0 2 “2”
A4: Current/FaderBank/Bank/Recall 0 0 3 “3”
B1: Current/FaderBank/Bank/Recall 0 1 0 “0”
B2: Current/FaderBank/Bank/Recall 0 1 1 “1”
B3: Current/FaderBank/Bank/Recall 0 1 2 “2”
B4: Current/FaderBank/Bank/Recall 0 1 3 “3”

Switching between A and B (got that working in a way using FaderBank/Select as a toggle switch using the on and off setting)
A: Current/FaderBank/Select 0 0 0 “0”
B: Current/FaderBank/Select 0 0 1 “1”

It looks like it’s mis-recognizing your console and thinking it’s a CL rather than a QL.
Can you fire up companion and just enable the info tab on the log page, and when it connects, you should see a line that shows:

Device found: 

and let me know if it shows QL or CL or if maybe that line doesn’t show?
I’m also looking at my files and I may have made an error in that some QL commands were labelled as CL, so that could be the problem right there.

Let me know what you find, and I’ll see about fixing this.

Thank you for getting me that additional info!

Device found: “QL1”, so it recognises the correct desk.

Ok, that’s good.

So, looks like a couple of commands that you needed were labelled as CL commands rather than QL.
However, I guess I never actually got around to filtering the list for the 2 consoles separately. 98% of the commands are the same for both consoles, the only differences are in the Custom Layers (of course).
So, for now, BOTH sets of commands are available, and if you use the wrong one, nothing will break, it just won’t do anything. If you use the Macro command, you should be fine, because the command is sent from the console and it can’t send a command that it doesn’t recognize!

But, for reference:

CL CustomFaderBank/A/SourceCh Choose channels in Bank A
CL CustomFaderBank/B/CentraOut/SourceCh Choose channels in Bank B
CL CustomFaderBank/C/SourceCh Choose channels in Bank C
CL CustomFaderBank/Master/SourceCh Choose channels in Master
CL FaderBank/A/Recall Select Left Bank layer
CL FaderBank/B/Centralogic/Select Select In/Out Middle Bank
CL FaderBank/B/CentraIn/Recall Select Middle Bank In layer
CL FaderBank/B/CentraOut/Recall Select Middle Bank Out layer
CL FaderBank/C/Recall Select Right Bank layer
QL CustomFaderBank/SourceCh Choose channels by Bank
QL CustomFaderBank/Master/SourceCh Choose channels in Master
QL FaderBank/Select Select In/Out?
QL FaderBank/Bank/Recall Select Fader Bank
QL FaderBank/Bank/Toggle ?

Maybe confirm the QL commands to see what they do exactly and let me know.

1.3.5b is up on the sticky. Give it a try. (Commands are still listed in the log when you start up, so you can verify)

Just downloaded the new version. Using the record matrix didn’t work before, but now it does!
I’m now able to switch user banks. Even got the visual feedback of which bank is selected. Great job!

Awesome! Couldn’t have fixed it without your help.

What’s “record matrix”?

When you have a moment, could you confirm the operation of the QL commands as per the table above? Let me know if they’re correct and what “Toggle” does.

typo… I ment Macro…
I’ll look into the rest tomorrow.