Using later CPS software with DTR radios

Hello, My name is Ben and I am having troubles programming my DTR550 radios. A few months back my IT department upgraded my laptop to windows 10 and when they did they removed the Business Radio CPS I had installed. I was able to have them reinstall R06.00 from Motorola’s website but now I am getting an error message when I try to read or write:

Communication Error.
For RM and RMM Series radio, please toggle the USB cable to ANALOG (CPS) mode.
For DLR Series radio, please toggle the USB cable to DIGITAL (Flash) mode.

After doing some research it sounds like the new version of the software is not compatible with the older firmware on my radios. I have been trying to find a copy of R03.01 and the only place that it seems to exist now is on these forums.

AFAIK, the latest CPS (v7 I believe) still works fine with the DTR series. I expect you have another issue going on.


I’m running into this same issue. I’ve tried the latest software link of 8.02 as well as 3.01 and get the same:

Communication Error.
For RM and RMM Series radio, please toggle the USB cable to ANALOG (CPS) mode.
For DLR Series radio, please toggle the USB cable to DIGITAL (Flash) mode.

I’m on Windows 10. The PC sees the USB to Serial Comm Port that I purchased from Amazon.

I’ve updated the radio firmware using the 6.01 and 6.05

Any help or ideas of what’s wrong?


The latest CPS is R08.02 and works fine with the legacy DTR410/550/650 models. I own a small fleet of DTR650 radios and R08.02 works fine with them.

Check your COM port settings in the CPS. The CPS defaults to Auto Detect COM Port for detecting the COM port used by the CPS cable. This works fine with the DLRs and new DTR600/700 models because they use the HKKN4027 CPS cable. The Auto Detect COM Port setting DOES NOT work with the older CPS cable for the legacy DTR410/550/650 models. You need to manually set the COM port in the CPS to match what COM port the CPS cable is actually using.

Fixing the COM port setting should work and enable talking to the radio.

Good luck.

I picked up a few second-hand DTR 650s that I’m finally getting around to programming, but I can’t seem to get the latest CPS version to talk to them using the 0105950U15 serial programming cable and a USB-to-serial adapter. Strangely, CPS R03.02 doesn’t have this issue and can talk to the radios just fine (and shows firmware version R5E.06.05, which I believe is latest). Do more recent versions of CPS require a different programming cable? (FWIW, the error message CPS R09.04 gives mentions switching the cable into different modes, which makes me wonder if it’s expecting the USB flashing cable instead of the serial programming cable?)

Conversely, is there any benefit to using more recent CPS versions than R03.02?



Edited to add: apparently one advantage of using later versions of CPS is that R03.02 crashes every time I try to delete a contact…

Hey Russell;

That’s odd…

Have you tried v8 CPS?

Finding older versions is tricky, but I just tried R08 and R06 with no better luck, so it seems like something is probably wrong with my USB-serial adapter. It turns out to have a CH340 chipset (which should be okay, I think?), but I’m wondering if more recent versions of CPS are having trouble setting up the port correctly (which might explain why R03 works).

What’s particularly strange is that the radio itself seems to know that something is trying to talk to it (it goes into CPS mode), but something is getting lost in translation. I might have to try and track down a different USB-serial adapter and see if that will solve the problem.

(Incidentally, it appears I’m having exactly the same problem as this person; I wonder if/how they resolved their issue?)


He says you need to manually select the COM port. I assume you did that and verified that it’s the correct port?
I would suggest another usb to rs232 adapter or check driver settings.

Yes and yes (there’s only the one). I even made sure I’m using the latest drivers for my USB-serial adapter. I may have to try and track down a different USB-serial adapter, but it does seem like something strange is going on. I broke out a serial port monitor (seemingly hard come-by on a 64-bit Windows system), and it almost looks like the first serial message being sent by the newer software is getting garbled (i.e. the older software basically only sent out messages that were four bytes long, but according to the monitor the newer software’s first message is only 3 bytes, which seems like a mistake).

I’ll order a different USB-serial adapter and see how that goes.


Let me see if I can find an older CPS version. I thought they were linked on this forum but the links seem to go to the Moto site which only has the v9.

Here’s a proper downloadable link to v5, see if that works.

I’ll give this a try later today; I also have another USB-serial adapter on order with (I believe) an FTDI chipset.

Also FWIW, R03 is touchy on Windows 10, but I did manage to keep it from crashing long enough to do a little programming (it turns out the secret is to only use the buttons in the toolbar, and also to save after ever change).


Wish I could help, but I sold off my DTRs and accessories years ago and can barely remember how they worked! :wink: