Can't connect to Rivage PM5

I’ve tried everything I know how to do. Took forever to get the editor connected but I finally got it connected through the DSP and not the surface. Still can’t get companion to connect using the same IP settings.

companion 2.3.0
Mac OSX 12.5.1 M1 processor
ip address - 192.168.53.1 subnet 255.255.255.0

PM5 Suface IP address: 192.168.0.1 subnet 255.255.255.0 (not currently connected to this)
DSP IP Adress: 192.168.0.104 subnet 255.255.255.0

any ideas?

I don’t have a Rivage, but my understanding is that the way to connect is the same as when using the MonitorMix app.
Here’s a video on how to connect.

Let me know if you get it working, maybe with your help I can create some specific instructions on how to connect companion to a Rivage.

Hi.
First, disclaimer as I’m typing this on my phone.

Second. Companion talks directly to the DSP. You’re not able to connect as you have your subnet locked down to where the dsp and companion can’t see each other.

If you need the editor connected, leave your settings the same and double your NIC, giving it a new address (you can do this in network settings. I can explain more if needed)
Give your computer another IP address of 192.168.0.xxx on 255.255.255.0 and point companion to use that network

I don’t need the editor connected. Please explain more about this subnet thing. I’m no networking expert at all… I just set my computer IP address in the range that the editor program told me to.

I watched the video and figured it out… Wow… I swear I’ve watch a million Yamaha videos and I always skipped that one because I have no intentions of using an IPAD… Thanks for posting it!
All about the correct IP addresses.

Yes, you did everything right for the editor, but that’s now how the connection to companion works.

Subnet, one way that helped me understand.
the subnet helps narrow down or open up the amount of connection you can have to other devices on the network.
With a subnet of 255.255.255.0, you are telling it that each of the first 3 ranges of numbers need to match in order to communicate. hence 192.168.1.1 and 192.168.1.101 will be able to see each other, but if you have a 192.168.10.1, that wouldn’t be able to connect because the 3rd octet doesn’t match.

That is what Companion and the PM5 DSP need to be on the same first 3 octets. 192.168.0.x (as you currently have your dsp on that range).

as I’m typing this I see you got it figured out, but if you have any more questions let me know. I’ve been using a companion / PM5 set up the past few months.

1 Like