Enabling Sends on fader on CL5 with companion

Hi Andrew,

First I’d like to thank you for everything you do here and on companion ! It’s amazing and very useful for us !
I’m sorry to bother you, but I want to use my stream deck with your MIDI module on a CL5 to have send on fader shortcuts for all 16 musicians I have on stage… But I think I missed something… Right now, I just tried on the editor, but what’s weird is that some commands work perfectly (on/off on a channel for example) but the send on fader does nothing… Even if I record a matrice, nothing appears…
(I tried on companion 3 with latest module and on your built companion 2.4 as well… same results…)

Thanks again very much for your time :pray:


Hello Antoine;

First, thank you for your kind words, I’m very happy to hear that my companion modules have been useful!

Before I get into how to fix the problem you’re having with SOF in the MIDI module, can I ask why you need to enable/disable SOF remotely?

Hello Andrew,

I need a remote for SoF because I have 16 musicians with IEM on stage and it’s really quicker to see their names (or pictures :sweat_smile:) on a button to select their mix. And also, I use custom button for other purposes…

Thanks again,


Ok, I understand. For some reason I was thinking that the MUSICIANs were selecting SOF, so that’s why I asked.

Ok, so when using the Editor, it’s important to remember that toggles won’t work and feedback can be a little funky. It’s because of the difference between how the Editor and Console communicate.

So, the command to enable SOF is:
Change the value from “Toggle” to “ON” (or “OFF”) to test it with the Editor.

Toggle (with appropriate Feedback) is still the best way when working with the console.

You’ll also want to add the KeySelect/KeySelectEncMix command to select the Mix (0 = Mix 1, 1 = Mix 2, etc.)

Hope that helps!

Yes, that’s what I did, but it does nothing… Even just the Keyselect… Even when I rec a macro, every action is recorded except the sel and SoF on/off…
(I might have told that before, but I’m on the 3.1.2 of companion…)
Thanks again

That’s strange, I just tested it and it’s working for me. I’m using a later beta but I don’t think anything should have changed that would affect this.
Here’s a video of it working:

Do you want to export that page and send it to me (DM if you don’t want to post it here)?

Thank you for sending me your page to test.

It works fine on my end.

Check that you have “Link between the PC and the console” enabled in the Channel Select / Sends on Fader option in the Editor setup.

Oh ! Don’t know why it wasn’t on… :man_facepalming:
I was sure I turned it on… It works now !
Thank you so much again !!!


1 Like