Feature request: TF variables in Companion

Thanks for all your work on the Companion module!

Would it be possible to add variables from the TF console for use by companion? I have two small use cases but would be a huge help for us.

One is simply to provide feedback to a button for color change if level is set to X OR > X. As it is now if the fader is moved slightly off the set level the feedback disappears.

The other would be to trigger an action in Companion if a channel input level is above X level. Basically be able to trigger based on DB level recieved on a channel or above a certain level on the meter.

I thought that was the custom build here but unless I’m missing something I don’t see these variabl3s available.

Thanks!

Thank you for your post and kind words!

Custom variables are supported, but I’m not sure if there’s a way (using triggers perhaps) to do something if the feedback value falls within a range.

Creating internal variables for the 1000’s of parameters within the console is not something I’d want to do, but I’m currently looking for a way to create custom variables that respond to feedback values, which might be the solution. Not sure how far off that might be or whether it would actually work.

The workaround for now would be to create a few feedbacks that have a value in the range of what need. e.g. if you want the color change to happen “around” 0db, then copy the feedback to be active at the values just below and above that, like -0.05 and -0.10 and 0.05 and 0.10, or whatever the smallest increment is.

Ok.
In my latest build, I added support for variables in feedback. They can either be used in place of a value, or unique to this build, they can also be set.
When using them to “get” (retrieve) a variable value use the normal $ sign as in $(internal:custom_Ch1_Fader)
When using them to “set” (store) a value into a variable, use the @ symbol as in @(internal:custom_Ch1_Fader)

Here’s a demo of a simple use for checking the value of a fader:

Andy,

Thanks so much for this! Im finally getting a chance to play with it but not having luck. There are no variables showing up when i start typing $(yamaha:XXXXX). The $ is also not showing beside the connection. Any ideas what I may be missing? Thanks!

They are custom variables. You have to create them first.
Look at the text of this post and the first pic in the next post to see how they are formatted.

@Andy . Got it working! I can’t wrap my head around what exactly is happening but it works regardless! :). Will this being going into the beta branch of Companion soon? This is awesome as is but I have a couple of issues that some other modules have since been fixed in later versions than are included? Thank you so much!

That’s great!

It won’t be in the beta just yet. What module(s) have been updated after mine?

I think there may be a few others but the main ones are Birddog PTZ 2.3.3 and Propresenter.

I see. And those modules are broken when you tested them using my build?

Andy,

So it looks like the iris controls on Birddog module work! That was what was broken I believe up until 2.3.3. But the documentation included says its version 2.3.1. Are the actual modules more up to date than the documentation says?

I do however get this error 3 times when starting companion even though it appears connected ok in the instance.

Thanks for all your help!

companionbuilderror

Scratch that Andy. Looks like the latest features in the Birddog Module like the new WB controls aren’t in this revision. The iris control does work though where it didn’t before. I guess this build was maybe a middle build I had not used before between previous breaks. Thanks.

Copy that. I’ll check and see how I can incorporate those latest updates. Let you know when it’s done.

New build up now that includes the latest modules from the latest beta.

@Andy . Thank you ! I see its pulled for Windows for now but will give it a shot as soon as it’s up!

Yeah, the Windows build is broken, I’ll post back when it’s fixed.

Well, that was a LOT of work to create the Windows build, but now I know how to do it so hopefully it’ll be easier next time!

Give it a try and let me know what I messed up this time! :slight_smile:

@Andy . Thanks again for all the work! I tried it out Sunday and for the most part it worked great!

One problem I found unless I’m missing something. When using normal button feedback for Fader Level INCH on this build you must add a .00 to each value. BUT I cannot get the feedback to work for a fader value of -500. I’ve tried -500, -500.00. -500.0. Nothing seems to work but I very well may be missing something simple. Any ideas?

Also using this method is it now possible to get a channel Input level into the feedback for triggers? For example like a audio level activated trigger rather than the fader level itself? Thank you so much! This has been so much help to us!

-500 is -5.00
0 is 0.00
+100 is 1.00
-100 is -1.00

The values are now in dB. Could also be that I’ve messed something up.

Ok so I did some more testing. I do think something is up. I could get it to work once with the action of setting mix to -5.00 and the feedback set to -0.05…The button would light once but once it was moved off that value it would not work correctly again until i reset it. It seems some fields are looking for .05 and some 500. Please let me know if i can help diagnose more.