How to connect streamdeck to QL1

Hi All,

Does anyone have a guide as to how to get the stream deck connected up to a QL1?

I understand its quite a basic question but am struggling at the moment for it to see anything!

Thanks,

Matt

1 Like

Hey Matt! Welcome!

  1. Download and install the latest companion build from this site. (You’ll need to wait for your account status to allow this, but it should happen quickly)
  2. Run it
  3. Open your browser to the companion admin page (click the “Open Web GUI” on the software)
  4. Add the Yamaha-SCP or Yamaha-MIDI module
  5. Click the “?” to the left of your instance (the name of the module) and follow the instructions
  6. You can use the Buttons page to create buttons, watch the video here on how to create macros
  7. You can test the buttons on the admin GUI
  8. Turn off the Elgato StreamDeck software if you’re using the physical SD.

Let me know where you get stuck!

2 Likes

Hey Andy,

How do you connect the Hardware?

Streamdeck -> MacBook -> USB MIDI -> MIDI Cable -> QL?

Thanks, kris

StreamDeck -> MacBook (or other computer) -> Network
QL -> Network (using the Editor connection on the QL)

“Network” can be a LAN cable, or a switch or whatever you normally use to network your computer to the console, the same way as you do for the QL Editor.

Hey Andy,

Thanks for your fast reply.
So the QL can receive MIDI over CAT and Network Port?
Wow.

Yup - You bet!

1 Like

2 posts were split to a new topic: How to download

A post was merged into an existing topic: How to download

I’m sorry… having trouble getting started… which ip address is the one for stream deck companion… for device control… or for.mixer control… seemed obvious to me… but the computer network port was pulling from the current ip setting for device control… so. I’m there… but I can’t get a connect… this console was just purchase used . I’ve tried dhcp on console auto and static… is their a best case… this console is not connected to anything else… and doesn’t need to be. … it does not matter what ip for this console… I just started working with it as it was… but to no avail… what is the factory ip… as this was previously manipulated… which ip setting should I be matching with companion… and how should it be configured… auto dhcp static… … I’m sorry to be so behind on this… I feel stupid… maybe I should factory reset console… but i usually learn more trying to diagnose … any assistance… even a screen shot of a working setup…

I have a laptop with a ethernet port… straight to ql1 connectivity network port… not dante… the computer recognizes their is an unidentified network… but I can’t connect companion software

Start off this way, to make sure your network settings are correct.

  1. Close Companion.
  2. Fire up QL Editor and get it to connect to the console. If it doesn’t, figure out why.
  3. Once you have the QL Editor connected and synchronizing with your console, close the QL Editor and fire up Companion.
  4. On the Instances page, click EDIT for the module you want to use (MIDI or RCP), and then set the IP address to the same as what you set in the QL Editor to connect to the console.
  5. Don’t select “Use Editor” if you’re using the MIDI module.

Let me know how that works for you.

I know they are not correct… this console was purchased used… and they have definitely been manupulated… was set to static… with a very unusual ip…

If you’re doing it that way, you’ll have to set your computer’s IP to a static IP address in the same range as your console’s “Mixer Control” IP.

Why not do a reset of the console?
Hold down master “B” select while powering on the console
Also, check the firmware. I believe the latest would be 5.70.

Had some trouble getting the computer to take a static ip… what do you recommend instead. I’ve put a router in between computer and console… hoping the router would establish ip… but the console… is locked in static Ip for mixer control… I cannot choose the dhcp button… am I way off track here… should I do a factory reset… and then… maybe be able to take the console out of static ip for mixer control… or is it always that way… console is supposed to be static only for mixer control ip

Reset console… downloaded editor… can’t get it to connect… is there a port setting… or is dhcp correct for PC… the console… for “mixer control” is locked as static… thou I can change the address… I can’t change to dhcp…

Ok
. Got the static ip to work… apparently you can’t do it in the screen directly from settings… but rather from the driver settings… probably just a problem for my computer… thank you… fornall your assists… I’m confident I can get it from here

1 Like