Random Error

Hey Andy,
first let me say that YammieQ is an awesome really powerful weapon, which already saved my life during a show.
Unfortunately there is a bug, which only occurs in run mode when YammieQ receives a trigger, but only randomly. I tried the software on 3 different machines (Win7 with CL-Editor, Win7 with CL3 console, Win10 with CL-Editor on OS X with Parallels). Same error message every time.

You find the error message and a screenshot attached to this post. Unfortunately it’s in German, but I hope you get all necessary information.


Hi Torben;

Thank you for reporting this bug. It might be tough to diagnose if it happens randomly, but please attach a zipped .ysw file so I can try to reproduce the problem. Let me know if there’s a specific way that you’ve found to make the error appear.

Hey Andy,
it doesn’t depend on the project. I’ve built several Little projects while exploring the software. The Same bug everytime.
One project, I already in a Show, is a Little switch to toggle between Main and Spare mic of an actor, changing the Patch and the eq of an Input Channel. So there are just 2 different states. So when you toggle these states the error randomly occurs. I will send the ysw file later, but I’m not very confident that it will help.

  • Torben

I understand, but I haven’t seen this issue since updating the software, so it would help to try it with a .ysw file that fails for you.

No problem.
In the attachment you find the .ysw file and a video of the error happening. I hope it’ll help.


Try this update and let me know if it works better.
Just unzip this file, change the filename of YammieQ.ex~ to YammieQ.exe and overwrite your YammieQ.exe file in the folder you installed it. No other files need to be changed.

I didn’t check the new version with the console yet but there have been no errors with editor. So the error seems to be fixed.


Good news. I’ve added the DM1000 console to the list now and updated YammieQ to 0.8.2 in the download thread.