Undefined and Nothing to configure after update companion(yamaha-RCP)

I used the previous version (2.1.3 or beta 2.2.0-5cc44b3a-3514) and updated to the new version (2.2.0). After the update, there was a problem with the settings of the Yamaha cl5, which was used well. An error message appears as shown below. Not all settings are available.

yamaha-scp3: scp_184 (undefined) Nothing to configure

There is no problem with the connection information. The label is also well set as the previous label.
I just updated it, but I can’t use the old settings. connection show up properly in the connection tab.

The phrase "scp_184 (undefined) " is odd in my opinion.
I’m using 3 stream decks with a companion.
The other companion shows the setting as “yamaha-scp3: Inch/Fader/Level”. However, the companion in question is “yamaha-scp3:” followed by “scp_184 (undefined)”.

other pc(windows) companion impormation.
previous version(beta 2.2.0-5cc44b3a-3514) : Yamaha Simple Control Protocol - v1.4.1

I think good that recover previous version (2.1.3) companion. but It is the same problem even if I change previous version of the app.

What should I do?

check this file~


  • OS: iMac osx 10.14.6
  • Browser: chrome 99.0.4844.84
  • Companion Version: companion-2.2.0-ccea40c7
  • Yamaha Remote Control Protocol - v1.6.4
1 Like

Got it.
The upgradeScript isn’t working properly, it’s going to take some work to figure out.
I’ll see if I can manually fix your commands in the meantime (depending on how many there are)

1 Like

I hope it gets resolved.
thank you

I have it working for individual pages but not for a complete config just yet.

I see you using a lot of latches for turning on and off things. You’ll want to change those to toggles which work much better with feedback and if something is turned on or off from the console, it won’t get out of sync.

I’ll let you know when I can get the full config to convert.

1 Like

Thank you Andy~
I also tried to fix the file by myself, but it was too complicated to try.

If you do each page one at a time, it seems to work. As I’m not having any luck importing the entire config, would that be something you’d like to try?
What I’m referring to is this process:

  1. Export your current config in it’s entirety
  2. Reset the config so it’s blank
  3. Use “Import” to bring in your old config from 1.4 (or 2.0, whatever the previous version was)
  4. Select Page 1 on the button page, select page 1 on the right and “create new instance” for each module, then import to page 1 at the bottom.
  5. Import that page
  6. Select Page 2 on the button page, select page 2 on the right and select the newly-created instance for each module, then select import to page 2 at the bottom.

Hopefully that makes sense. If so, and you’d like to try, I don’t know how many of the pages you need, but you only have to do the ones you use.

If you want to try this, let me know if you need a Mac or Windows build and I’ll create a build that lets you do that.

1 Like

I tried with the solution you suggested,
but it didn’t work.
So I reinstalled the previous version and restored it.
The previous version I restored is ‘companion-2.2.0-5cc44b3a-3514-mac-x64’(beta version).
If the problem is not resolved, the upgrade will be difficult.
The pages I need are pages 1 and 3 for CL5
I’ll try another way too.
thank you.

My upgrade procedure won’t work without a new build from me, that’s why I was asking if you are on Windows or Mac. It would be a special build just to allow you to import.
I’m working with BitFocus to try and figure out why the upgrade is not working, hopefully I’ll have a solution soon.

1 Like

I will try your new build in the upgraded companion. However, it is difficult because it has to be used immediately on the three hardware devices currently in use (iMac, windows, linux) and will be applied when stability is secured after testing on other PCs. Thank you for your hard work.

Understood. Let’s just wait then until there’s a solution from BitFocus that addresses the importing issue. I’m working with them to figure this out and will let you know when there’s a solution.

1 Like

I got it~
Thanks for your kind explanation.

Ok, thanks to the work and fixes done by the companion team, I have a fix that seems to work!

You can do the upgrade yourself, or I can run the upgrade and export the pages you’d like if you’d prefer to not run the beta for your shows.

MacOS Build
Windows Build

@sangjun - did you have a chance to try this yet?