WEIRD - Unit ID's All Reseting to "1234567891" When Updating Firmware

I’ve purchased a bunch of older DTR550s off of eBay recently and have run into a difficult problem. I’m updating the firmware on these using the two firmware programs that are provided in the main sticky thread here -

After about four updates on the older DTR550s (some of them have stubby, fixed antennas, while others have the short removable antenna), I’ve realized that the first firmware program (the intermediary one) resets the factory unit ID to “1234567891”. So all of the units that were upgraded have this same ID and can’t be differentiated by other DTRs when you try to contact just one of the radios. They all act exactly the same, so for instance, if I change the unit name to “John Smith” and send an OTA contact update - all of the radios with the “1234567891” ID now will show “John Smith”. If you make a call to “John Smith” on another radio, it will be received on ALL of the “1234567891” unit ID radios. Not good.

So now I have three questions and I’m hoping that someone here can help, as this might be the best resource for these radios.

  1. Has anyone experienced this before?
  2. With the radios that I haven’t updated yet, do you know of a way to make sure that the unit ID isn’t reset to the 1234567891 number with the firmware update?
  3. With the radios that are updated, do you know of a way to change or reset the unit ID so they’re different and will act as separate radios?

Hoping someone can help with this tough challenge, otherwise I’m going to have a handful of radios out of commission and wasted cash…

Just checking to eliminate possibilities. Did you perform a reset after the flash?

Quote from the flash guide:
After flash, the radio needs to be reset by doing the following, in order for the radio to go back to the normal mode.
• Remove the programming cable
• Turn the radio on
• Hold the Home key and press the PTT button three times
• Release all keys
• Press the Down, Up and Right Software keys sequentially
• Hold the Home key and press the PTT button three times again.
You should see the radio restart

I have flashed over 30 radios, mostly DTR550, but a couple of 650’s as well. Some were the early models with the stubby antenna.
I have never seen the issue you are experiencing. Hopefully what Chickenhawk mentioned (and you haven’t done the reset) is the cause and fixes the problem.

Keep us posted!

Ah! I have not, let me give that a shot.

That did the trick, thank you for the suggestion.

That’s good news!

I tried to emphasize as much as possible how important it is to follow the instructions when flashing. Your experience shows to reinforce the importance of doing so.

LOL! Yes, Andy is very correct. Thanks to his generosity, I was able to flash six radios, and I needed to read the instructions CAREFULLY. I wanted to flash them on Windows 8.1, so I needed to carefully follow the instructions for Windows 7, and run the software in Windows XP emulation mode. By the way, it worked just fine.

Yes, I’m a bit embarrassed that I missed that in the directions. Should always follow them to a T. I’m glad I’m not out several radios though!