Generic MIDI module not loading

I downloaded the generic midi module and imported it into companion and added it as a connection. However, I get stuck right there.
It says “Unkown Disabled” and “waiting for connection to start”.

What am I missing?

Hello and welcome!

What version of companion are you running?

The generic-midi module is now part of the Companion Beta, so you don’t need to download it if you’re using a recent beta version of Companion.

I was running 3.2.2, just installed the latest beta, but same result. It says “Unkown Disabled” and “waiting for connection to start”.

I’m on MacOS. My “Streamdeck” is an Android Tablet running the surface in Chrome Browser.

I currently am using it to send Key Commands to Logic Pro via the VICREO Listener Connection, which works great.

I wanted to add Midi to send CC and maybe do some readouts, like the timecode in one of the videos.
I am thinking of Mackie Control Protokol CC to read out information, if that is possible.

Ok, thank you for verifying that.

While using the beta, you disabled the developer module path, correct?

Can you send me the main logs (log tab - export support bundle)
and the module logs (click on the >_ icon between the $ and trash icon:

and select Export Log

Send me both of those so I can see what’s going wrong.

My guess is that you might not have any MIDI devices on your system, but really, it shouldn’t error out like that.

Andy, I found the error.
I tried to install “Midi Monitor” and it said, I should delete any old Midi Drivers that I do not need anymore in Library/Audio/Midi Drivers.
There, I had an old Native Instruments and an old Waves Soundgrid Driver.
I deleted both, restarted, and now it is working.

1 Like

Cool! Good to know.


A post was split to a new topic: Feature request: generic MIDI auto-reconnect