Google Sheets not working in custom build?

Hi Andy,

Wasn’t sure if I should open a new thread for this but I thought I’d ask here. I cannot get the Google-Sheets module to work on the custom build. It does work on the download from bit focus. Wanted to let you know. Not sure if it is a fluke or if it is something that could be fixed. Thank you.

That’s strange!

What exactly doesn’t work or what error are you seeing?

The credentials from Google Cloud Console are correct and this config is the one that worked on the bit focus build. I created a new project and tried all new parameters as well and it showed the same error. Then tried it on the bit focus one and it worked.

Ok, thank you for clarifying!

I’ll see if I can update the my companion build.

This is going to be SO much better in v3 where you can add modules separately from Companion!

Yes agreed! Thank you for checking on it!

This is what I am working on setting up, using the built in Google Sheet Function to check the value in the Google Sheet and apply it to both our CL5 and QL5 at the same time. One button that can be pressed and rename everything based on the Google Sheet and then eventually set to where each individual button can be pressed to rename only that single channel if needed. It’s working well so far but missing the functionality you added so that I could create the custom variables for the console channel to compare the name in the console to the name in the Google Sheet and highlight it red if there is a mismatch.
I’m thinking about having the button layout as follows:

name from Sheet variable
name from console custom variable

Would be very small text on the button so not entirely sure.


I was just trying to test GS on my copy to see if it worked, but I see that getting google Cloud set up is a chore in itself, so I’ll pass and assume you’re set up properly as it works on the “official” release.

While I’m working on this, could you post the “Help” page for GS from the official companion version?
The one in mine is version 0.1.1

Oh, are you on MacOS or Windows?

I am on Mac

Also, that is the same that is showing on their main page.

Potentially good news and I’m not sure if it’s a work-around or not, but I removed the custom build and only had the bit focus build on my MacBook and had the sheets module working, I then re-downloaded the Custom module and when I opened it, it kept my same configuration include the Enabled Google Sheets module. I’ll troubleshoot it a little bit to make sure it wasn’t a fluke but it appears to be working.

Oh! Interesting.

I did do an updated build that I’ll upload anyway, just in case there’s been any other changes since the last time.

1 Like