Is it possible to control the Recorder via Companion?

Is it possible to create a button (or to record a macro) in companion which acts as play/pause button in the recorder of a CL/QL console?
So you can start/stop the music playback via a press on a Stream deck button.

Should be able using the MIDI module. Give it a try!

Ok, so when recording a Macro and pressing the transport buttons, the messages come in as VolatileRecorderControl/RecorderStatus
Keep track of the value for each message (I think Channel is always 0) and change the message to Recorder/RecorderStatus with that same value and it seems to work.

Just testing here, so far I’ve got for values:
Play = 2
Pause = 6
Stop = 1
Rec/Pause = 34
Rec/Play = 33

Thanks for the fast action!
I was also experimenting with it last sunday, but without result. I will check it again one of the next days.

Check back in a few days. I’m finding there’s more commands that might be useful, like choosing the track #. I’ll see if I can document them better. Nudge me if you don’t see a reply soon. :slight_smile:

Checked this with a QL1 console. When I use the “Record Midi Macro” button, the function is recorded, but when I press the buttons afterwards, nothing happens.

So for example the “play” button says:
Press actions:
Message name “VolatileRecorderControl/RecorderStatus”
Channel 0
Value 0
Release actions:
nothing
Feedback:
nothing

Another example, the “stop” button says:
Press actions:
Message name “VolatileRecorderControl/RecorderStatus”
Channel 0
Value 1
Release actions:
nothing
Feedback:
nothing

When I press these buttons in the emulator, nothing happens. (for your information, other recorded functions do work, for example “Console lock”, “Mute master 1”, etc.)

I also tried to press, after starting recording the function, first on the recorder button, to record “open the recorder” before pressing the “play” or “stop” button in the recorder menu. Also without positive result.

Did you change the action as I suggested?

New build uploaded yesterday. Not sure if you’re using that or a previous one?

Hello Andy, thanks for your reply.
I replaced “VolatileRecorderControl/RecorderStatus” by “Recorder/RecorderStatus”, the control buttons (play, pause, …) react, they indicate their status by turning green or white and also near the track appears a “Play” logo or a “Pause” logo, but the music itself doesn’t react (start playing or gets in pause).
If I press play on the QL1, the music starts playing, but then also, the commands I send from the Emulator give only changing the colours of the touch screen buttons of the QL1 as result, the music keeps playing. Also the track time keeps counting and the time-bar keeps moving.

The version I used was your build of some days ago, so probably the previous one.

I use the MAC version, by the way (don’t know if that matters)

Oh! That’s interesting. I thought because the buttons were responding, the tracks were playing.

Will have to play some more with this to see what the “trick” is!

I’d like to be able to start/stop the recorder via a button on my Streamdeck, but I’m having difficulties getting it setup. I’ve tried recording a MIDI macro. No luck. I don’t see any RCP or MIDI actions that control the transport controls. Is this possible? I use it to play unlicensed music for our broadcast mix prior to an event.

Haven’t figured it all out yet, and likely won’t have time to work on this feature for a while.
There’s no RCP command and not likely that there will be, so I expect it’ll be a MIDI only command if it ever does get implemented.